Modify default metric for redistribution, Enable route redistribution, Enable – Brocade Multi-Service IronWare Routing Configuration Guide (Supporting R05.6.00) User Manual
Page 215: Route redistribution, Example using a route map

Multi-Service IronWare Routing Configuration Guide
187
53-1003033-02
Configuring OSPF
Modify default metric for redistribution
The default metric is a global parameter that specifies the cost applied to all OSPF routes by
default. The default value is 10. You can assign a cost from 1 – 65535.
NOTE
You also can define the cost on individual interfaces. The interface cost overrides the default cost.
To assign a default metric of 4 to all routes imported into OSPF, enter the following commands.
Brocade(config)# router ospf
Brocade(config-ospf-router)# default-metric 4
Syntax: default-metric value
The value can be from 1 – 15. The default is 10.
Enable route redistribution
NOTE
Do not enable redistribution until you have configured the redistribution route map. Otherwise, you
might accidentally overload the network with routes you did not intend to redistribute.
To enable redistribution of RIP and static IP routes into OSPF, enter the following commands.
Example using a route map
To configure a route map and use it for redistribution of routes into OSPF, enter commands such as
the following.
The commands in this example configure some static IP routes, then configure a route map and
use the route map for redistributing static IP routes into OSPF.
The ip route commands configure the static IP routes. The route-map command begins
configuration of a route map called “abc”. The number indicates the route map entry (called the
“instance”) you are configuring. A route map can contain multiple entries. The software compares
routes to the route map entries in ascending numerical order and stops the comparison once a
match is found.
Brocade(config)# router ospf
Brocade(config-ospf-router)# redistribute rip
Brocade(config-ospf-router)# redistribute static
Brocade(config-ospf-router)# write memory
Brocade(config)# ip route 10.1.0.0 255.255.0.0 10.95.7.30
Brocade(config)# ip route 10.2.0.0 255.255.0.0 10.95.7.30
Brocade(config)# ip route 10.3.0.0 255.255.0.0 10.95.7.30
Brocade(config)# ip route 10.4.0.0 255.255.0.0 10.95.6.30
Brocade(config)# ip route 10.5.0.0 255.255.0.0 10.95.6.30
Brocade(config)# ip route 10.6.0.0 255.255.0.0 10.95.6.30
Brocade(config)# ip route 10.7.0.0 255.255.0.0 10.95.6.30 5
Brocade(config)# route-map abc permit 1
Brocade(config-routemap abc)# match metric 5
Brocade(config-routemap abc)# set metric 8
Brocade(config-routemap abc)# router ospf
Brocade(config-ospf-router)# redistribute static route-map abc