beautypg.com

Dell POWEREDGE M1000E User Manual

Page 980

background image

38-88

Cisco Catalyst Blade Switch 3130 and 3032 for Dell Software Configuration Guide

OL-13270-03

Chapter 38 Configuring IP Unicast Routing

Configuring Multi-VRF CE

Switch(config)# interface loopback2

Switch(config-if)# ip vrf forwarding v12

Switch(config-if)# ip address 8.8.2.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface gigabitethernet1/0/5

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

Switch(config-if)# no ip address

Switch(config-if)# exit

Switch(config)# interface gigabitethernet1/0/8

Switch(config-if)# switchport access vlan 208

Switch(config-if)# no ip address

Switch(config-if)# exit

Switch(config)# interface gigabitethernet1/0/11

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

Switch(config-if)# no ip address

Switch(config-if)# exit

Configure the VLANs used on Switch A. VLAN 10 is used by VRF 11 between the CE and the PE.
VLAN 20 is used by VRF 12 between the CE and the PE. VLANs 118 and 208 are used for the VPNs
that include Switch F and Switch D, respectively:

Switch(config)# interface vlan10

Switch(config-if)# ip vrf forwarding v11

Switch(config-if)# ip address 38.0.0.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface vlan20

Switch(config-if)# ip vrf forwarding v12

Switch(config-if)# ip address 83.0.0.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface vlan118

Switch(config-if)# ip vrf forwarding v12

Switch(config-if)# ip address 118.0.0.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface vlan208

Switch(config-if)# ip vrf forwarding v11

Switch(config-if)# ip address 208.0.0.8 255.255.255.0

Switch(config-if)# exit

Configure OSPF routing in VPN1 and VPN2.

Switch(config)# router ospf 1 vrf vl1

Switch(config-router)# redistribute bgp 800 subnets

Switch(config-router)# network 208.0.0.0 0.0.0.255 area 0

Switch(config-router)# exit

Switch(config)# router ospf 2 vrf vl2

Switch(config-router)# redistribute bgp 800 subnets

Switch(config-router)# network 118.0.0.0 0.0.0.255 area 0

Switch(config-router)# exit

Configure BGP for CE-to-PE routing.

Switch(config)# router bgp 800

Switch(config-router)# address-family ipv4 vrf vl2

Switch(config-router-af)# redistribute ospf 2 match internal

Switch(config-router-af)# neighbor 83.0.0.3 remote-as 100

Switch(config-router-af)# neighbor 83.0.0.3 activate